MCD2 tRIEA [ 15
B3, SR

11 e ANBLERAIAE, K= D RN e R A B OGEK Y, FT T O6EE N\mplab ide SCHEYE, AT R
MPLABV6.60.EXE JT U 225 3 A
1.2 $Z PR ERAE AT A 1) 222 22208 58 UG 1% RGP BB R B L.
TEECAE WINOS 223 1E6.0 [FF 85, MPLAB IDE 6.XX 22358 5 A |E I Bon 5 S, #% 1E6.04E
4, 2 JGie4T MPLAB IDE 4 L EvE S SR iR .
filt R 7 F B RS 2R PR 1E6.0 TGV A R 5 1 (0 2 A& 4 A 1 21 WINDOWS 1y
WM. RBEHAT X:/Program FilesMPLAB IDE/dIIg/egister.bat {8 1] fi# v 1) 5
WHR LRGP RAEASREFT TP BT R, AT RS YR AE 2 S A0l 5, X i AR B FRATT I 9 3l “ B R Bk}
— R FEB N —> MPLAB IDE V6.60 %%,

B, WEBORME. CEAERE)

2.1 4TJF “FIE " BEA PRI, PAT PRI R ARG, HEN PR A (R X i
AN BIX il “3ii (COM Al LPT)”, Tt FU I AL A7 A1 1K) JLA 3 1.

2.2 WLAERE R FRATT MCD2 g LA i A 1 AT B (FE R W B LU M CD2 A i i 5 1A H 11188 USB 111), Wit Al
T E A @i G 0 (COML) », Bhi i th COML B PE v E %, #BEA “ui M ” —4%, KR Em
WO REE, 1A

xR
W WOGE | wd |

T [ Poro GHE TR Taes0 WS WART) (1]
a0 (128000 x R R M L T P
EEED = [ dmE o (il P
EANEE), [T =
O g X
e LA -
. | EERUED | om WOg e [ *

23 il “Hg (A BEANZZPH AT, OCH] 8 LT AIFO Z2ah DX RIRE A i i 4 2531, B
2.4 BEELF A siily “HE 7 IR S G0 E, TR R R DR R, O P R A BRI DL R R A
2.5 HT A Bl U DA T A A A

P=. USB KSR 3.

3.1 HIBENICE N USB HH#41EH: MCD2 FHLZ M, SEn] DOANRIERH FARE s i . (. Ll usB
g, FHBEYLHEIE A MCD2 EHLHEHD
3.2 Hgx e Fi . (PIC16-MCD2 i FHUE I ) U2 20 -2 23 i,
WG ANELELSE MPLAB IDE 6.XX Hi¥f MCD 2 5 PC il USB %4z,
(] BRZEESE, AH2E TR, REBRBERISCHRTFREA, FHEREES) H-F38 0 IEFH
I SCAER?
ey R BNIXAS A, AT LGB H IR S e e g, gE NSRBI . R R G RO S, R R,
ATEFNZR T RIGIEREAS, AT R P B, SRJ5 8 0 H FR AT Sl as ", A A 2% $a il
B, BENBIIRE) SCAFIE, B IE RS .

$IUZE. MCD2 ¥

4.1 4%} MCD2 RECE MPLAB IDE
4.1.1 e REREERE MCD2 EHL N CBE— i g iU H EIEHD, AR5 FHBENLECE HIE S MCD2 F:41
ftr, AR MCD2 EHLSH F HR/IDEMO R, JeANERZS F P Al F (B P AR AT BT oK H MCD2 SEHLIK HLJ i 2
).
4.1.2 Fi4 MPLAB IDE
1
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{E423858 MPLAB IDE {5, AT T AR —Fh 72K 8 3 e
o % FFeE> FEF>Microchip MPLAB IDE>MPLAB IDE.
« WHiMPLAB IDEKIHr
« $IYTMPLAB IDEZ %% 4% F\dlls ¥ H 5 F ymplab.exe.
4.1.3 EFERM
{28 B X 15 HE Configure>Select Device Kk MCD2 Tk (1) #14 (A b i £ 5256 A T e s Ay

PIC16F877A). MCD2 Jir s F¢ [M#{437E Microchip T H 3 HF F 'S #:4 MPLAB ICD2 5511 — Nk bR AL
RS oA — A 20T Bbw. BT AR RS B T L8, HE oA FRL Bk, nrReAE & T8 TR HE
A LAk MCD2 125 A8 H] .
4.1.4 WMEAMKRE.

A FH IC B o7 2 £ 0HE HE Confiqure>Configuration Bits >k & 241 15 H ) il &4,

* Oscillatot iz /7 28, WA REAFBEATIE 8, dnA i i) MCD-DEMO Mt ) BRIA D XT 755, 3kAl

LR FER T 77 A XT .

« Watchdog Timer & 1HMEAEAL, H MCD2 /IR T L EHZ I — 2 Eik 4 off

«Power Up Timer FHIZERMEREST, —MEFEN on AT 85 kg die.

« Brown Out Detect s H M REAL, H MCD2 /E R T B I —w Bk FE N off

* Low Voltage Program fik/k4mefilifie, 1] MCD2 it —i& 2Lk 4% 4 Disabled

* Flash Program Write 5 FLASH {{ifig, F] MCD2 1F i3 T 5 — & Bk $% 4 Write Protection off

+ Data EE Read Protect i EEPROM {x4'fiz, H] MCD2 {F il T H I — & ik 4 off

« Code Protect &7, H MCD2 #EIHR T H N — & Bk $ 4 off
4.15 ¥'E MPLAB ICD2 4 BRA T A

#%#% Debugger>Select Tool>MPLAB ICD2 ¥ MPLAB ICD2 1/ ik T H. — H XA T Hylak e )n, Ml

AT MPLAB IDE T A2 Won IRIERY. [MII, frh & H 43497, 0T ICD RS FE K15 B4 /R MPLAB
ICD2 #2852 . (M ICD2 1E M TR B Frbe 5 rfe s HEeH T 05 sk, ARSI, #ZRS Relli
WAL, w2kt Programmerr>Select Programmer>MPLAB ICD2 ¥ MPLAB ICD2 1F 4w 2 T 2D
4.1.6 FLEREH

Bk 2| Debugger>Settings ) Communication, E#¢ USB 2 M 8% %) RS-232 il il £y COM .
4.1.7 B MCD2 B FRIERGE) (LFT s @i A 14 MCD2 &5 PC)

A MPLAB IDE HJRAS B g R I, Sfdon — 205 BB R 7 2 208 . MPLAB IDE K B 222 58 i i 1.
SH U HE QB B

ICDAW 2mil0E ICD2 is aboud o dowsrinad & rews opedalivg ystem. |l
WMPLAR 1 just slartng it il appear o “hang'! ot He splach screen. Please
be patieet. MPLAE wil finish s intizlization after the 05 & dowrbaadad
[Note: Yiou may wish ta select bo ignore this saming in the lue.]

[ Dian't dzply this warno agan

0K

[FEE, BT ANE ) MPLAB ICD2 Al i1 H T AR RS PIC B ML, MUIHASF G PIC 5 5 LIt n G H B
XN AE.
[ 4 Y A2 B TR 2 3R B B 0K
1. #%#% Debugger>Download ICD2 Operating System. %$% ICD2 [l S RHTHE 23T IT.
2. MR ) Y s o B A SO SO A LR icdxxooaxx. hex, e ook SRR . 6T
MPLAB IDE $& it ASI¥15 B T LL A README S8 MPLAB ICD2.txt AR E£E 1) PIC #84FRATT B

3. it Open. MPLAB IDE ¥ N #08 f1#:1E 2 4 3 MCD2.
4.1.8 N A HIR

EEXT MCD2 A H AR VF 22 AOECE, 1 X LS i A (1 OG5

* HEHUSBIEESL N, MCD2R] UMWPCHIK A L. HAAZREELT HARMRSE A i CGRIUMCD2 E R —AMBEHL
2
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B AR, AR Bid EDEMOMBAE FH >k AMCD2 BN H . D
o A HIRS-232 £ BIPCHLIN, MCD2 25— A HLUA.
« MMCD25—AE QI HIERS, T LR/ B ARRTESV R N 4 it — 52 5 1 HL UL, 35 1T I 200mA- (AR
K EKIMCD-DEMO T Ik HEMCD2 EHLI FLIED
« MCD2ANGEIH b H AR A H.
o TE45 H AR L2 HT, 56 45MCD2 0 H.
4.2 H{MCD2%: B ARt fit H it b H B
i FH R THI TR K AEMC D24y H bsAR At i, X ANALE L AR VFAEBY, 5 200mAHL I R A .
1. 45MCD2inH. ANELy H AR L.
2. JAZIMPLAB IDE6.xX.
3. 7EMPLAB IDE[HAZE R~ ik $Connect.
4. 7FEH5MCD2## v im )5, P Debugger>Settings.
5. AREMHIES, fidiPowerdrss, #iik”Power target circuit from MPLAB ICD2”#¢ikH . fidiOK.
4.3 L BHsE — AN ML B R B B )RR
i XA K45 H brbici g e B SRk Bl X FIXAECE, HbsmET LS 2-5V, i nf LAl MPLAB
ICD2 $e i H it s, A PIC iy HLEHE T LA XA #8540 A B i s Y L
ZEMCD2IN . ANE LT H R .
JA ZIMPLAB IDE6.xx.
{/EMPLAB IDE[) A1 .~ i Connect.
fESMCD2# v il il 5, P Debugger>Settings.
ERCEXEHES, fidiPowerdbs s, #iih”Power target circuit from MPLAB ICD2” % k. riddiOK.
s HRRS L, ARGk Debugger>Connect.

Fi.. MCD25E}%:

X NHE R R oAl R med-ledl.asm KA 2401 Kk — AN DR SR IXAMEIREAE MCD2 ¥ 77 i L4256 4 1)
MCD-DEMO % #2545 SCAF I rhm] LUAR B, X ANFE P A H ARG MCD-DEMO 8 7R S HL PICL6F87X [ /K AT .
5.1. FEREHLECEICHE T Imed-dem o S SO AN 5 2 W fiw (R A b ks SopR e A AudE B2 B BRSOk
A 44 A S B T (A 7R MPLAB SR YR 7 BRI H 1) SCPE 48 DA SCAE - BEASRE 5 A7 H Sl 775 o)
5.2. fEJTURIX EEAEFE 21, 2 AR DY 2 (1) 5 B A CE AIMPLAB IDE#PE. #EiX B4 w0 — S A3 B vl BEAE 25
U 2 B E AT
— H 35, MPLAB IDE 5 [ . 1% 27 i 3-1.

s MFLRD TDE w550
Bl Ede Ve Presel Dalbudsli | Pragnsrar Confipre 'Andes Hl-b

=R-1-E 1|
5.3 A ATF BARK

oY | Chinckimm: ®a741
R

1. %+% Configure>Select Device.
2. TEBMFIERTIRHE, AR1ES RHELL S PICI6F877A. 7E Microchip T H 7 £ 43 45 MPLAB ICD2 ()] P ¥z

o0k whPRE

V1% K S f.

3. riifi OK.

5P MCD2 15 N i 25

1. %#f Debugger>Select TooI>MPLAB ICD2. i Huks < s ] AL i ey ilde 1ot [wlinF, e s 1
SHATIF BoRIEAR B

2. L$¥ Debugger>Settings, WlAR4E. EFE USB 2l COM i /R 3.

3. WHRAHE MCD2 Hahi%s:, MdRRArRS, EHAutomatically connect at startup”..(f5 I H glE 2 A
TR, S BSOS i T ) BR L)

4, ILREEDVUE 4.2 (A0 DR G E Y.

3
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5. i OK.

6. 1t#t Debugger>Connect i%#:%| MCD2.
54T IENS
FEIXATREH, MPASM J1 4 g 2 A .

1. #%# Project>Project Wizard >k 37 5 — A~ TF2.
2. HEATEISE AN FXEAE, PIC16F877A M A% 4L .
3. EEHHAT RIS N — /X IEAE, KE MPASM fEhiE F T H. 7E"Active Toolsuite” T $i 71| £ 1 ik
$’Microchip MPASM Toolsuite”.ffiik MPASM Fl MPLINK ¥ % 7E MPLAB IDE\MCHIP_Tools SC1F32 AR N
A AT S B MPLAB 1% E fE MPLAB  IDE\dIls ST {4 J& (1 A N B $ AT SC A ;MPASM 1. $57 5E #
mpasmwin.exe,MPLINK [ §5 2 | mplink.exe, MPLAB I #f 5 2| mplib.exe[## 4 LN 1] BEK REEANRE S MPLAB
528 IEAA R IE T 7R 28 =20 MPLAB I tH 21 (A R s X AR A5 2 N R I A 4 e M, 7 250 132k vp 2 — T
MPLAB Librarian(mplab.exe), %X Ji si47111f] Browse %4, $ (Ml Ze%4%(C 8¢ D ):\Program Files\MPLAB
IDE\dIIs\MPlab.exe fiii ] I, X I FATT LLE ) MPLAB [R5 5& 7 1E6f B bk 1 80 20 (6 0 b 2, 0 R 22 1)
Trep Tee P - =
Edlaci & Dumpusge tealamite {1‘"} E‘:/.
"
ot Toood i Mochp MPESE Tooknss R ——— -
o Brsc e
TRl § o e |
B Mo et
Laaian B MDD HES i |
|l: | Pragram Filas\PLAE IDE\ S 1M Flak i [[[EY ety
B medsdl COD
TR R Pragl— = etk
P T it so[FFom] wa | mm |
midi B, HN DRSO R H 4 DL S R Ar I H S0 CREBUR AR BINE RS 3 7] — A 3ok, TH 44
J 2SR BA A TR ) A TR SO I 21 1) 5.
s NSO, s BUAE BLJS I I R T AN Gk B WA S AR A ) med-ledlasm, ik
mcd-ledl.asm KiEH e, R)G A ADD>>S¥EEIRINBA L AR, W b4 K.
M N E XA TR SO L e i, U 57 R )R
55 HFILHE
B 35, MPLAB IDE S20 S as L. SCPTE e i & H VAR TR O, TR O N B A2 B s,

=10

P ity iy - : Buiid Iﬂ.nd. im Filan| WPLAB ICD 2
= 5\?'\-"“:3 " teleting intermediary files... done
Bizrmr b weouting: “DriFrogras Files\NFLAR IDENMCHIF_Tools'\MPASIYIN, EXE'
Cbrject: Plen rosaps [H2] ErvCHJECINECI=LEDL, 2SE 22 : FRegister in operand not
Library Files vaded EiregmoatimodeLad], COD
Linker Ecripts

UILD FCCEEMED: Sat Jul 05 19:13:52 2004

WERAE S, SCPEAT UL shras in ) TREE H. K ehst 80 %) Source Files”8¢"Linker Scripts”kas i, 2
Br—AN S0, wTLAGeiErh e, ARG i U A B, MR BB SO
5.6 fIE HEX X
FN R —N HEX S0, 1 Project>Build AN ERAE TR 1 HL 1) TRE 4 7 b i A Bl O AR PR S o I
EFE"Build All”. MPASM V1% it 23 LLasm SCERAR A1 46 7 A2 B— A hex SCER S 3 R i an B4 .
5.7 WEIFREIR
5.7.1 FeEAL
T ERCE AL, E$ Configure>Configuration Bits. il s ili"Settings” 41| L) SCA ] LIS ST THH TS 2. 7EIX
ANKFEHE T, BT RX E i R, T 10 R TC A 1% A
* Oscillator — XT(iX &% XIMCD-DEMO. 1 58 FH e i H bRtie, NgEAT A7 Y. 1) A8 5T)
* Watchdog Timer - off

* Power Up Timer - on
* Brown Out Detect - off

* Low Voltage Programming — Disabled
4
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* Flash Program Write - Write Protection off
» Data EE Read Protect - off
» Code Protect - off
« Background Debug — Enabled (i KA i 75 £k 10 1. 1% 10 H /EMPLAB IDEV6.6011 L F A AE 7, i FMCD 21
A R a4 Kok S5 IRALAE F R -5~ % 151 2 Disabled.)
5.7.2 2L

BYEE g FEIE TN, 4E$¢ Debugger>Settings k)5 it Program Frss.

s 10D e sebtiean i

Biwtmn | Comsemicstios | Lisitwtios |
Fruar Propas | arciens Funings

rpra— Fragan Cnne
F P e

F F

I~ EtPADM

o

r

Frogram Menos) adderss:
[ma]

i [ —
e [T —
o PEPRAFAE RIS N iZ " Program”i 1, “EEPROM R’ ID” ANi%k. 44l FIMCD24E h R A% i, 1e B 0K — B FE,
THC 5 226 PR AN e 06 v I A K 5
o FEIPAAAE A ik (RS 46 M B 45 RO Bk ) F R BB R P A A 28 IV B, R, gmf BRSe . AiidiFull Range i & ik
Tk A T B KR P AR A A MY L SRR A A A 1) S5 R A T R AR, DUOR B (] 25 MC D21 1A R
Fe. 4l FHMCD21E A I, B e A Al Fifn i) B (8 FHMPLAB V6.60LL i AR I mI B #1% H Allow ICD 2 to
select memories and ranges)
5.8 WEBEAR
FEITFUE AT, ik MCD-DEMO 7~z i F E47 ¥ &
o il HIBEEEI3,J4IEFEXT OSCIEIH  » BEZkS14HEON. o HEHPMCD2 EHLHL L.
5.9 A ARG
1% $¢ Debugger>Program ¥ mcd-led1.hex %i ¢ %] MCD-DEMO j# 7~ _L (1) PIC16F877A.
Y] RETFE LR B, FEGMAERLRE A, B XS HE MPLAB ICD2 £ 2 SR ERVEI M ar B B, Mgmfe s iy, 6 iEHERN
Z4nkE 3-10 iR,

ol
Build | Pird in Filax MPLAE 17003 |

. .-Frogramming Dsbuy Yactac

i« Frograsming Configaration Bits
VeriTying. .,

. .-Frogram Basary

. . -Dabug Bxecutive

1o by Weotor

| e Yarify Soaoesdad

. .-Froprasmang Confagurstion Btz
.. Canfiy Namery

oo Frograsming socesdsd

WFLAD ICD 2 Beady =1

LR -:lj_

5.10 &84T MCD-LED1

MCD2 AJ DA L2 i Bl B0 R U AT

+ fEMPLAB IDEfig 4745 30+ ,MCD-DEMO3# /-8 L [(IPIC16F87 7 AK i 47 78 Sz A5 2.
o (EARFRER Y LIS, BOD ATk BE U ).

A L mT AR 15 PR R A R DR v i)

S T AP S TAF
sty [ BT
ik [nn] AT
IR GO EW

1. #7JF MCD-LED1.asm SCAF(7E TR 1 EXGE S04 8048 H Eile>Open).
2. ¥ Debugger>Run (g% & T EA RUN $#441)
3. TEE/RM L, Wi LED mvmshid f2 R4S,

5
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4. E¥ Debugger>Halt(m s T HA HALT $241) 1 frisqr.
5. 1E# Debugger>Reset 5 i fLFE.
5.11 #i& MCD-LED1
T AT A — TR EBEL1E MCD-LEDL R 5 1 TAF.
* DEMOJF KA B HON.  « DEMOMR % 1 Bk Be B AT, « REF P BEHNAS FERT TAEAIER.
BIWLEE T A7 A5 I SUROIRAS, ] DAZE R P AH DG Ak 15 5 WK 25
1. M mcd-ledl.asm & o RO BRTBCE AE 22 B T RO R T — AT
btfss  flag,0 ARG, LB BRI 2R
2. RiAEE, BRI,
3. M SEIRERE Set Break Point. X —ATHLYERE bR ic A Wi sl (20 A1) B 45 1bdxid). a1 N 22 Bos.
4. &P Debugger>Run (8 i T HA% RUN % 41) BASE B R s 1T 727
MR PAT B W B EATIS, WS s R Ras AT, AR, GRS  HaL.
5. ¢ Debugger>Halt(zk fith T HA% I HALT $241) ok 1L RE .

CIET— Ligix]
Add 5FR ”ADEDND vl Add Symbol"flag vl
Lddress | Symbol Name I Value |
ooz5s flag as

[watch1 watchz [ watch 3| watch 4]

6. THAIFLF, % Debugger>Reset. #— 484 NiZ W — a0 k.

7. FIF NS RS FHATIN FLAG A AA 4 1024k, EF¢ View>Watch. MEXIHHENS Watch_1 i%
HETTE. IS N Symbol 53R i flag”, K5 s e d"Add Symbol”.flag #7 NEDW S 1. A
KT s,

8. FULHATILRE, W Debugger>Step (8l it T A A% STEP $441).

9. TEMLEE P & A7 474 FLAG IIMA.

10. % FEFile>Save #1734+

11. EFProject>Build ALL F## TR, — 45 DS PR TP p Sl gt v, ZAP UL A2 3%, MCD2 A 25 i H T .

12. ¥$Debugger>Program & 4 2. élMPLAB ICD2%} i HE i 7R, . .Programming succeeded’, F2 /7 5t 7] LAY 1t
NIE {7,

13. (B2 A E W AT s A B, £ $ERemove Break Point.

14. EFDebugger>Run e Fia 4778 S . g i # Kk OB 7ELED 7R R 1.

X U5 AR R — MR R, AR, PR AR R BB T 2 ). i FHIMCD2FIMPLAB IDE A ) g, HI

FE D () A HI A8 523X 8 i) i

5.12 FE
YRR A AT, NP PIC R ML BT Re LIS AT, M TIX— 2P0, $ MCD2 &

B TR D R Tilees

PN AT e, mT DA% IR T D R

#E# Debugger>Select Tool>none 5[4 MPLAB ICD2 1f 4 ik T A.

7F Programmer>Select Programmer 3% .1 i% £ MPLAB ICD2 1 4 4w f4 25

7t Programming>Settings 2 FFhr%s s E T IS 5L

£ Programmer>Program.

PRAERe e FE PP 0 s B LI AT T, FRAT T AT AT A5 F P AR 28 P AR b sk I 8278 7 1R AT

(#: MCD2 W7 H [T & 56 W T FH P B 3 MCD2 (& #e4k, AR5 Wi 7F MCD2 EHLIMAMH YR, 55 il MCD2

] PC #EHek, b d iy D)W 4 AF ) o
S 224 I ) s A U A R S AN, UG AT B R M
PIC B HLAA ST hitp://www.picl6.com  http://www.cxgmeu.com

LR

2005 % 2 H
6
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